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Chapter 3: 
Adding & Formatting Text
Formatted text is the most basic component of any book.

Formatted text forms the basis of most books. After all, books are normally 
meant to be read and what you read is text.

This chapter explores some of the ways to add text to a document, including 
typing it in or importing documents created with Apple’s Pages app or Micro-
soft Word. It then explains how you can format text so it looks the way you 
want it do. 

But first, let’s begin with a more thorough discussion of how the various types 
of pages and text boxes work.

Understanding Pages & Text Boxes
Each template includes several different types of pages, each with its own purpose. 

Page layout is template-specific, although you’ll see many similarities from one tem-
plate to another. For example, you’ll notice that each template’s page layouts include 
text and image placeholders for you to insert your text and images.

In this part of the chapter, I tell you more about how pages can be used to add 
content to your book. I also explain how text boxes work to display text a variety of 
ways.

This file is a sample chapter from iBooks Author: Publishing Your First 
Ebook, a Maria’s Guides book by Maria Langer. You can learn more about this 
book on the Maria’s Guides web site, www.mariasguides.com/iBooksAuthor

http://www.mariasguides.com/iBooksAuthor
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More about Pages
iBooks Author supports three basic types of content pages: Chapter, 

Section, and Pages. 

 � Chapter pages Each chapter begins with a chapter page. This is a 
single page that includes the chapter number and name as well as some 
informational text. Chapter pages tend to be graphic intensive, with 
large images that help differentiate the chapter start from other con-
tent. There are two kinds of Chapter pages:

◊	 Chapter A standard chapter opening page (Figure 3.1).

TIP A book doesn’t need to have a Preface, but if you want to include one, you’d use 
the Preface chapter page to add it.

Figure 3.1: The Chapter page for the Contemporary template.

◊	 Preface A special chapter opening page for the book’s Preface 
(Figure 3.2). In the book’s organization, the Preface comes before all 
chapters and includes introductory material. 
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Figure 3.2: The Preface page for the Contemporary template.

 � Section pages Each chapter may have one or more sections, each of 
which begins with a section page. Sections define a second level of the 
book’s structure, normally beneath the chapter level. iBooks Author 
offers five types of section pages:

◊	 Section page This type of section page includes a text box for  list 
of items, such as a section content list, as well as a text box for the 
section’s beginning text (Figure 3.3).



26

iBooks Author: Publishing Your First Ebook Chapter 3: Adding & Formatting Text

a Maria’s Guides book

Figure 3.3: A Section page in the Contemporary template.

◊	 Section Text page This is an alternative section start page that 
includes two columns of regular text (Figure 3.4).

Figure 3.4: A Section Text page in the Contemporary template.
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◊	 Copyright This type of section page appears near the beginning of 
the book for the inclusion of copyright information (Figure 3.5).

Figure 3.5: A Copyright page in the Contemporary template.

◊	 Dedication This type of section page also appears near the begin-
ning of the book. It’s used to indicate who the book is dedicated to 
and might also be used to acknowledge the help you received from 
others when creating the book.

◊	 Foreword This type of section page also appears near the begin-
ning of the book, before the Preface (if included). It could be used 
for introductory material written by the author or someone else.

 � Pages Pages are normal text pages beneath the chapter and section 
levels. In most instances, your book will consist primarily of plain 
pages. There are four different types of pages: 1 Column, 2 Column 
(Figure 3.6), 3 Column, and blank. One of these —normally the 2 
Column page—is also listed as the Default and is used when iBooks 
Author needs to create additional pages to accommodate text overflow.



28

iBooks Author: Publishing Your First Ebook Chapter 3: Adding & Formatting Text

a Maria’s Guides book

Figure 3.6: The default page in the Contemporary template has a two-column 
layout.

It’s important to remember that the appearance of each type of page 
varies depending on the template. Throughout this book, I use the Con-
temporary template as an example; the Basic, Classic, and Craft tem-
plates, for example, will look very different. They all, however have the 
same basic construction and use.

Adding Pages
When you create a new iBooks Author file, it starts out with three 

pages: a Chapter page, a Section page, and a regular text page. These 
appear in the Book pane as thumbnails or an outline (Figure 1.1 and 1.2).

There are four ways to add pages to your book:

 � Use the Pages submenu under the Insert menu This submenu (and its 
submenus; Figure 3.7) enable you to insert any kind of page you like.
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Figure 3.7: Use the Pages submenu under the Insert menu to add pages.

 � Use the Add Pages button on the toolbar This button is really a menu 
with submenus for adding any kind of page you like (Figure 3.8).

Figure 3.8: The Add Page button is really a menu full of options for adding pages.

 � Use contextual menu commands When you right-click the Book pane, 
a contextual menu appears (Figure 3.9). Two commands add pages:
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Figure 3.9: You can also use a contextual menu to add pages.

◊	 Add Page The Add Page command adds a default page to the end 
of the section selected in the Book pane.

◊	 Insert Page The Insert Page command adds a default page before 
the currently displayed page.

 � Use the Chapter from Pages or Word document command This com-
mand, which can be found under the Insert menu, adds an entire chap-
ter or section based on an imported Pages or Word document.

Removing a Page, Section, or Chapter
Removing a page, section, or chapter is simple. 

1. In the Book pane, select the item you want to remove.

2. Press Delete. 

3. A dialog may appear asking you to confirm that you really do want to 
remove the selected item (Figure 3.10). Click Delete and the page, sec-
tion, or chapter is removed.
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Figure 3.10: A dialog like this might appear when you delete a page, section, or 
chapter from your book.

Changing a Page’s Layout
Once you’ve added a page, you can change its layout—within limits.

For example, you can convert one type of Section page to another type 
of Section page or a regular Chapter page to a chapter Preface page. You 
can’t, however, change a Chapter page to a Section page.

1. In the Book pane, point to the page you want to change. 

2. Click the triangle that appears in the lower right corner to display a 
menu (Figure 3.11).

Figure 3.11: Use a pop-up menu like this to change a page’s layout.

3. Choose the layout you want to use. The page layout changes 
accordingly.
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TIP You can also customize the layout for a page by moving or reformatting text 
boxes, by changing the background image, or by making other changes to a page’s 
design; I cover some of these things later in this book. 

Text Boxes & Placeholder Text
In iBooks Author, text appears in text boxes. Although many pages 

include text boxes all ready for use, you can also create your own. In addi-
tion, you can modify a text box to change the number of columns or its 
physical size.

TIP You can see the boundaries of text boxes and other layout elements by display-
ing layout boundaries as shown in Figures 3.1 through 3.6. Choose View > Show 
Layout Boundaries, or press Shift-Command-L.

Text boxes that are part of a template include placeholder text, as 
shown in Figures 3.1 through 3.6. Placeholder text is mostly standard 
“lorem ipsum” style gibberish that is meaningless yet helps you visualize 
how your own text might look in the same space.

Placeholder text is easy to replace—just double-click anywhere within 
the text box to select it all and type or paste in your own text. Or, with 
placeholder text selected, you can press the Delete key to remove it 
entirely and enter new text later.

If you enter more text than can fit in a text box, iBooks Author auto-
matically creates a new page and flows the text into it. The two text boxes 
are said to be linked.

When you create your own custom text box, the text you enter into it 
is not part of the regular document flow. You might use a custom text box 
for a sidebar or heading with additional object styling applied. For exam-
ple, I use custom text boxes for Tips in Maria’s Guide books; this makes it 
possible to apply custom borders and shading and wrap text around them.

TIP You cannot link two custom text boxes to flow text from one to the other.
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Adding Text
When I think of books, I think of words—of text to read. Words are the 

most basic component of most books, so you’ll likely want to include them 
in yours.

iBooks Author lets you add text to your document in several different 
ways:

 � Type directly into the document You can type text directly into a text 
box within the document.

 � Copy and paste You can copy text from a source document and paste 
it into a text box in your iBooks Author document.

 � Import from Pages or Word You can import formatted text in an Apple 
Pages or Microsoft Word document into iBooks Author as a chapter or 
section of the book.

 � Drag and Drop You can drag the icon for an Apple Pages or Microsoft 
Word document into the iBooks Author Book pane to add it as a chap-
ter or section of the book.

In this part of the chapter, you’ll try each of these techniques.

Typing Text
The  most basic way to enter text into any document is to simply type it 

in. Let’s do that by typing in the title for the Chapter page.

1. In the book pane, click the Chapter 1 page to view in. 

2. In the main part of the window, double-click the word Untitled to 
select it (Figure 3-12).
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Figure 3.12: Double-click placeholder text to select it.

3. Type Forces in Flight. The text you type replaces the selected text 
(Figure 3.13).

Figure 3.13: Whatever you type replaces whatever was selected.

Adding Text with Copy & Paste
You can also add text by copying it from one document and pasting 

into a text box in iBooks Author. Let’s give that a try with the chapter 
introduction text, which goes right after the title.
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FILE If  you haven’t downloaded the exercise files for this book, now’s a good time 
to do so. You can find them at the support page for this book, www.MariasGuides.
com/iBooksAuthor.

1. Open the file named Chapter Intro.txt in the 1-Flight Forces folder in 
the Exercise Files folder. This is a plain text file that should open in 
your default text editor (Figure 3.14).

Figure 3.14: The Chapter Intro file, as it appears in TextEdit.

2. Choose Edit > Select All, or press Command-A, to select all of the text 
in the document.

3. Choose Edit > Copy, or press Command-C, to copy the selected text to 
the Clipboard.

4. Close the document to get it out of the way.

5. On the Chapter 1 page in iBooks Author, double-click the placeholder 
text beneath the chapter title to select it.

6. Choose Edit > Paste, or press Command-V, to paste the text from the 
Clipboard into the text box, replacing the selected text (Figure 3.15).

http://www.MariasGuides.com/iBooksAuthor
http://www.MariasGuides.com/iBooksAuthor
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Figure 3.15: The placeholder text is replaced with the text you pasted in.

Importing a Document
If you have a Pages or Word document that contains the text for a 

specific chapter or section, you can import it into iBooks Author with or 
without formatting. Let’s give that a try by importing a Word document as 
the first section of this book.

1. If the book already includes a Section 1 page, select it in the Book 
pane, press the Delete key, and click the Delete button in the confir-
mation dialog that may appear to remove it.

2. Choose Insert > Chapter from Pages or Word document.

3. In the standard Open dialog that appears, locate and select the exer-
cise file named Basic Aerodynamics.docx, which you can find in the 
1-Flight Forces folder.

4. Click Insert.

A dialog like the one in Figure 3.16 appears, prompting you to pick a 
layout for imported content. 
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Figure 3.16: Use this dialog to specify the type of page you want the new content to 
begin on.

5. Scroll down to the first Section page and select it.

6. You have the option of including the paragraph styles of the imported 
document. Turn on the check box under the scrolling list of layouts.

7. Click Choose.

A few things happen: The formatted text is imported into the body text 
box of the layout. Overflow text flows into a text box on a second page. 
A Document Warnings dialog appears; it lists the fonts it substituted to 
ensure iPad compatibility. You can see all this in Figure 3.17.
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Figure 3.17: Here’s the document window in full-page view immediately after 
importing a Word document with paragraph styles preserved.

8. Close the Document Warnings window to get it out of the way.

What we see here isn’t exactly what we want because the formatting 
assigned to the imported text wasn’t what we need for our iBooks book. 
We can fix this later by assigning different styles. But if your source docu-
ment is formatted properly when you insert it, there’s a good chance it 
would be fine as is, other than possibly needing bit of editing.

Adding Text with Drag & Drop
You can also use drag and drop editing techniques to import a Pages or 

Word file into its own chapter or section. Let’s give that a try now.

1. Arrange the windows on your screen so you can see into the 1-Flight 
Forces folder and your iBooks Author folder.

2. Drag the icon for the file named Four Forces.pages from the Finder 
window to the Book pane in the iBooks Author window (Figure 3.18).



39

Chapter 3: Adding & Formatting Text iBooks Author: Publishing Your First Ebook

a Maria’s Guides book

Figure 3.18: Drag a document icon into the Book pane to start the import process.

A dialog like the one in Figure 3.16 appears, prompting you to pick a 
layout for imported content. 

3. Scroll down to the first Section page and select it.

4. You have the option of including the paragraph styles of the imported 
document. This time, let’s not. Turn off the check box.

5. Click Choose.

A few things happen: The unformatted text is imported into the body 
text box of the layout. Overflow text flows into text boxes on the next four 
pages. You can see some of this in Figure 3.19.
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Figure 3.19: In this example, I’ve imported unformatted text from a Pages document 
into a new section.

Because the text is not formatted, you’d need to apply formatting as 
necessary; the next chapter explains how.

TIP Personally, I prefer importing unformatted text as shown in Figure 3.19. This 
enables me to apply consistent formatting throughout my document, using styles I 
define within iBooks Author. Keep in mind, however, that you can always override a 
source document’s text formatting by applying new formatting in iBooks Author.

On Your Own
Here are a few practice tasks you can do on your own:

 � On the first page of Section 1:

◊	 Edit the title to remove the -1. 

◊	 On the left side of the page, edit the column heading to say Topics 
Covered:. This text will  be entered in uppercase per the style 
applied to the placeholder text there.

◊	 Use Cut and Paste to move the four topics covered from the main 
text column to the list in the right column. If you do this just right, 
the placeholder text should be replaced with a properly numbered 
list.
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◊	 In the right column, remove all the text before the word Before.

 � On the first page of Section 2:

◊	 Edit the title to read The Four Forces in Flight.

◊	 On the left side of the page, edit the column heading to say Topics 
Covered:.

◊	 Replace the placeholder text under the left column’s heading to 
include these words, pressing Return after each one except the last: 
Lift, Weight, Thrust, Drag. Each one should appear on its own line, 
properly numbered. 

More About Text Boxes
So far, you’ve worked with the text boxes included on layout pages. 

These text boxes are automatically generated on each page. But you can 
also create your own custom text boxes—for example, for a pull quote or a 
sidebar that isn’t part of the normal text flow of a chapter or section.

This part of the chapter tells you a little more about how text boxes 
work. It also explains how you can create a custom text box in your book.

Text Box Links
As you’ve seen, when you import text into iBooks Author, it automati-

cally creates pages with layout text boxes to display it. It’s also smart 
enough to create a new page when you run out of space in the layout text 
box you’re typing in.

Behind the scenes, iBooks Author is connecting text boxes together 
to ensure flow from one to the next. To see the links between text boxes, 
click on the edge of a layout’s text box. Blue connection lines appear from 
the end of one box to the beginning of the next (Figure 3.20).
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Figure 3.20: You can see the text box connection lines when you click the edge of 
one of the text boxes.

TIP You might find it easier to click the edge of a text box if you can see it. Choose 
View > Show Layout Boundaries, or press Shift-Command-L to display the boundar-
ies or edges of all layout objects.

 Here are a few things to keep in mind about text boxes and the links 
between them:

 � Chapter and Section pages Chapter and section pages are not con-
nected to the pages before then. Each chapter and section has its own 
text flow.

 � Automatic links When you add a new text page to your book, iBooks 
Author automatically connects its text box to the one on the previous 
page.

 � Text Overflow If text doesn’t fit in a text box, a tiny square with a plus 
sign in the middle of it appears in the bottom center of the text box 
(Figure 3.21). You’ll need to link that text box to another one (or make 
the text box bigger) for all the text to appear.
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Figure 3.21: If text doesn’t fit in a text box, you’ll see a square with a plus sign in it.

Removing a Link
If you need to, you can remove the link between two text boxes.

1. Display the link connection lines.

2. Point to the blue box where the connection line meets the destination 
text box and drag it off that box (Figure 3.22).

Figure 3.22: You can drag a connection line off a text box to sever the link.

The connection line disappears in a puff of digital smoke and the link is 
broken.

Adding or Changing a Link
You can also add a link from one text box to a new one or change an 

existing link so it points to a new text box.

1. Display the link connection lines.

2. Click the blue box in the bottom right corner of the text box you want 
to link from.

A dark gray box with instructions appears (Figure 3.23).
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Figure 3.23: A box with instructions appears when you click the blue box in the 
bottom right corner of a text box.

3. Do one of the following:

◊	 To create a new text box linked to the one you clicked, click or 
drag on a page. The new text box appears and text flows into it as 
necessary.

◊	 To remove an existing link from that text box, click the blue box 
again. The link is removed.

◊	 To cancel the linking operation without changing anything, press the 
Esc key.

TIP Using this technique to add a new text box makes it possible to create a custom 
linkable text box that continues the flow of the chapter or section text.

Creating a Custom Text Box
You can create a custom text box that is not part of the chapter or sec-

tion text flow. This is especially useful for pull quotes, sidebars, and other 
shorts bits of text you want to have different treatment in the document.

Let’s give this a try. Follow these steps to add a text box with a pull 
quote to the middle of page 5 of the book:

1. In the Book pane,click page 5 (the second page of Section 2) to view it.

2. On the toolbar, click the Text Box button.

A text box appears in the middle of the page (Figure 3.24).
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Figure 3.24: A text box is inserted in the middle of the page.

3. Click inside the text box to select the placeholder text (Figure 3.25).

Figure 3.25: Click the placeholder text to select it.

4. Type Newton’s Third Law of Motion: For every action there is 
an equal and opposite reaction.

This text replaces the placeholder text (Figure 3.26).

Figure 3.26: The text you typed overwrites the placeholder text.

This text box has an obvious problem: it overlaps other text in the main 
text box. Fortunately iBooks Author enables you to wrap text around 
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objects such as text boxes. You’ll learn how in the section titled “Wrapping 
Text Around Objects” in Chapter 5. For now, just leave it as it is.

Text Formatting Basics
So far, all we’ve done is enter text into the iBooks Author document. 

Some of that text was automatically formatted:

 � Placeholder formatting If you overwrote placeholder text, the text you 
typed or pasted in appeared with the same formatting as the place-
holder text you replaced.

 � Imported text formatting If you imported text from a Pages or Word 
document and indicated that you wanted to include paragraph format-
ting, the source document’s paragraph styles were copied to iBooks 
Author.

In many instances, you’ll want to change the formatting of text in your 
document. You may want to apply bold or italic formatting to specific 
words. Or you might want to apply heading styles to text that wasn’t for-
matted when imported. Or maybe you just want to make a global change 
to the way a heading or body text looks.

This part of the chapter covers the basics of text formatting so you can 
get a better idea of the available options and choose the techniques that 
are best for your book.

TIP iBooks Authors supports all of the text formatting options you’d expect to find in 
a full-featured word processor. Its interface is remarkably similar to that in the iWork 
Pages application. Rather than write dozens of pages about each formatting option 
you can apply, I’ll let you explore the formatting options on your own. If there’s a 
specific formatting change you need to make and it isn’t obvious how to do it, consult 
iBooks Author’s onscreen help. It should point you in the right direction.
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Direct Formatting vs. Styles
iBooks Author works like most word processing applications in that it 

supports two types of formatting:

 � Direct formatting You can apply specific formatting directly to 
selected text. This modifies just that text. The benefit is that it’s quick 
and easy to do. It even feels natural, which is why so many people use 
this technique. The drawback, however, is that it makes it very difficult 
to consistently format text throughout your document.

 � Styles You can apply a character or paragraph style to selected text. 
When you apply a style, you apply a collection of formatting options all 
at once. This is easy to do—if you already have a style defined with the 
formatting you want to apply. The benefit of using styles is that when 
used exclusively for formatting, it’s very easy to consistently format text 
throughout your document.

I am a huge fan of styles—and you should be, too. Although they can 
take a bit of extra effort to set up, that effort pays off later when you 
decide to make a global formatting change. 

For example, suppose you decide that you want level 1 headings to 
be bold, 24 points, and red. You apply those formatting options directly 
to text you’ve identified as a heading. Later, you realize that the book’s 
color scheme would be better with blue text and you like the look of a 
completely different font. You’d have to go through the entire document 
to find every heading you formatted and manually apply the new format-
ting options to them. In a long book, this could take a while. But if you’d 
defined the Heading 1 style and applied that throughout your document, 
you could quickly change the color and font of all level 1 headings by 
simply redefining the style. And you wouldn’t have to worry about missing 
any headings when you made changes, either.

Although this book does explain how to directly apply formatting 
options to selected text, it concentrates on using styles instead. I urge 
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you to use styles whenever possible in all of your documents—not just in 
iBooks Author. 

Someday, you’ll thank me.

Character vs. Paragraph Formatting
Another distinction that needs to be made up front is the difference 

between character and paragraph formatting:

 � Character formatting Character formatting is formatting that can be 
applied to selected characters of text. It includes formatting options 
such as font, font size, font color, and font style. You select the text 
characters you want to format and apply the formatting option(s). Only 
the selected characters change.

 � Paragraph Formatting Paragraph formatting is formatting that must 
be applied to entire paragraphs of text. It includes formatting options 
such as line spacing, alignment, spacing before or after paragraphs, 
and bullet or numbered list formats. You select all or part of the para-
graphs you want to format and apply the formatting option(s). All text 
in the selected paragraphs change.

iBooks Author—like so many word processing applications—supports 
both character and paragraph styles. As the names suggest these types of 
styles can be applied to either characters or paragraphs and change the 
text accordingly.

What may be confusing to some people is that paragraph styles can 
include character formatting. So, for example, you can create a paragraph 
style that includes a specific font size, color, and style (i.e., 14 pt, red, 
bold) as well as paragraph formatting (i.e., 1.2 line spacing, bullet list). 
When you apply that to a paragraph, both the character and paragraph 
formatting options are applied.
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Directly Applying Formatting
iBooks Author offers many different techniques for applying formatting 

to selected text. Let’s take a look at them. 

Using the Format Bar
One of the most basic ways to change the formatting of text is with the 

format bar. This is a horizontal bar of buttons and menus that appears 
right under the toolbar (Figure 3.27).

Figure 3.27: The format bar appears under the toolbar.

TIP If the format bar is not displayed, choose View > Show Format Bar, or press 
Shift-Command-R to display it.

The format bar is very easy to use. Simply select the text you want to 
format and use the buttons or menus to apply formatting to the selection.

Rather than present a tedious list of all the buttons and options on the 
format bar, I suggest you use tool tips to learn more about them. Point to 
a button or menu and read the information in the yellow box that appears. 
Figure 3.28 shows an example. As you’ll see, the format bar buttons and 
menus cover just about any text formatting option you’ll need.

Figure 3.28: Point to a button to see a tool tip that explains what it does.

TIP All items on the format bar other than the first three apply direct formatting to 
selected text; they do not apply styles.



50

iBooks Author: Publishing Your First Ebook Chapter 3: Adding & Formatting Text

a Maria’s Guides book

Format Menu
Many text formatting options can be found under the first two sub-

menus on the Format menu.

 � Font The Font submenu (Figure 3.29) offers a number of character 
formatting commands.

Figure 3.29: The Font submenu under the Format menu offers character formatting 
commands.

 � Text The Text submenu (Figure 3.30) offers a limited number of para-
graph formatting commands.

Figure 3.30: The Text submenu under the Format menu offers a number of para-
graph formatting commands.
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To use these menus, select the text you want to format and then choose 
the appropriate command. 

TIP Using a command on either of these menus directly applies formatting to 
selected text; it does not apply styles.

Using the Fonts Panel
Like most Apple applications, iBooks Author includes access to a 

standard Fonts panel (Figure 3.31). You can use options in this panel to 
format selected text.

Figure 3.31: You can also use the Fonts panel to apply formatting to selected text.

To open the Fonts panel, you can click the Fonts button on the toolbar, 
choose Format > Font > Show Fonts (Figure 3.29), or press Command-T.

TIP The Fonts panel is a floating palette—not a dialog. That means you can keep it 
open while you work with iBooks Author so its options are always handy.

TIP Formatting text with the Fonts panel directly applies formatting to selected text; 
it does not apply styles.
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Using the Text Inspector
The four separate panels of the Text inspector (Figure 3.32) offer access 

to a wide variety of character and paragraph formatting options. You can 
use these options to change settings for selected text.

Figure 3.32: The four panels of the Text inspector offer lots of formatting options.

To open the Text inspector, click the Inspector button on the toolbar 
and then click the Text button near the top of the inspector. You can then 
click buttons near the top of the Text inspector to view the four panels of 
settings:

 � Text The Text panel controls color, alignment, line spacing, and para-
graph spacing.

 � Lists The List panel controls list settings, including the list level and 
indentation.

 � Tabs The Tabs panel controls paragraph indentation, default tab set-
tings, and custom tab stops.
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 � More The More tab includes miscellaneous other settings, such as 
borders, rules, background fills for characters and paragraphs, the style 
automatically applied to the next paragraph (when you press Return at 
the end of the paragraph), pagination, breaks, language, hyphenation, 
ligatures, and baseline shift.

TIP Formatting text with the Text inspector directly applies formatting to selected 
text; it does not apply styles.

Applying Styles
As I discussed earlier in this chapter, in the section titled “Direct For-

matting vs. Styles,” a style is a collection of formatting settings. When you 
apply a style to selected text characters or paragraphs, you apply all of the 
formatting options at once. 

iBooks Author comes with a bunch of predefined character and para-
graph styles that you can apply to selected text throughout your docu-
ment. The actual appearance of these styles varies from one template to 
another. Each has a specific purpose; for example, the Chapter Title style 
is for chapter titles and the Body style is for the main body text. If there 
aren’t enough styles to meet your needs, you can create new ones.

TIP If you import a Pages or Word document with styles applied to text, those styles 
are copied to your iBooks Author document. We can see this in our example file; the 
heading 1 and heading 2 (as opposed to Heading 1 and Heading 2) paragraph styles 
were imported with the Word document we imported earlier in this chapter.

iBooks Author’s placeholder text has its built-in styles applied, but you 
can override them if you like by applying different styles (or by directly 
applying font or paragraph formatting).

TIP Some of iBooks Author’s styles are special. For example, the Chapter Title, Sec-
tion Title, and Heading 1 styles are among those used by iBooks Author to generate 
headers and table of contents information (among other things). For this reason, it’s a 
good idea to use the correct style for each purpose.
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Although a complete discussion of styles is beyond the scope of this 
book, in this part of the chapter, I explain how to apply and modify styles. 
Along the way, we’ll spruce up the example book we’ve been working on.

Using the Style Menus
One way to apply styles to selected text is with the style menus on the 

far left end of the format bar (Figure 3.27). The first menu is for para-
graph styles; the second menu is for character styles. Let’s take a closer 
look at how they work. Section 2 contains a Pages document that was 
imported without formatting. We’ll apply iBook Author’s built-in styles.

1. In the Book pane, click the thumbnail for Section 2 to view it.

2. Select the first paragraph in the right column on the first page of Sec-
tion 2 (Figure 3.33).

Figure 2.33: Select the text you want to apply the style to.

3. Click the Paragraph Style menu on the format bar to display its 
options (Figure 3.34).
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Figure 3.34: The Paragraph Style menu on the format bar. 

Note that the style named Body has a check mark next to it. This style 
is already applied to the text. When you import text without formatting, 
the placeholder text style is automatically applied. 

4. Release the Paragraph Style menu without making any changes.

5. Position the insertion point anywhere in the  line that says Lift.

6. Use the Paragraph Style menu on the format bar to apply the Heading 
1 (not heading 1) style. 

The text on that line changes (Figure 3.35). Note that because this is a 
paragraph style, you don’t need to actually highlight any text. The style is 
automatically applied to the entire paragraph where the insertion point is 
blinking.
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Figure 3.35: The Heading 1 style is applied to the paragraph where the insertion 
point is blinking.

7. Repeat steps 5 and 6 for the headings that read Magnus Effect and 
Bernouli’s Principle. 

Both paragraphs are formatted with the Heading 1 style.

You format text in custom text boxes the same way.

8. On page 5 of the document, click anywhere inside the text box  you 
added to the middle of the page to position the insertion point there.

9. Use the Paragraph Style menu on the format bar to apply the Block 
Quote style. 

The style is applied to all the text in that paragraph. This makes the text 
bigger so it no longer fits in the box; you can see a plus sign in a square at 
the bottom of the box, indicating that some of the box’s contents do not fit 
(Figure 3.36). We’ll fix that problem later.

Figure 3.36: The text gets larger so some of it is no longer visible in the text box.

10. At the beginning of the third paragraph on page 7, select the phrase 
Form drag.

11. Hold down the Command key and, at the beginning of the next para-
graph, select the phrase Skin friction.
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Both phrases are selected at the same time (Figure 3.37). This makes it 
easy to apply formatting to multiple blocks of text at once.

Figure 3.37: iBooks Author enables you to select multiple blocks of text at once.

12. Click the Character Style menu on the format bat to display its options 
(Figure 3.38).

Figure 3.38: The Character Style menu on the format bar.

13. Choose Emphasis.

The selected text becomes bold. Because this is a character style, it 
applies only to selected text.
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Using the Styles Drawer
Another way to apply styles to selected text is with the Styles drawer, 

a window pane that slides out from the main window and offers access to 
paragraph, character, and list styles (Figure 3.39).

Figure 3.39: The Styles drawer offers easy access to all paragraph, character, and 
list styles

To display the Styles drawer, click the Styles Drawer button on the 
format bar, choose View > Show Styles Drawer, or press Shift-Command-
T. The Styles drawer slides out on the right or left side of the window; 
if your window fills the screen, you may have to make it smaller so the 
Styles drawer can appear.

Let’s finish formatting Section 2 of our book using the Styles drawer.
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1. On page 5, position the blinking insertion point anywhere in the head-
ing for Newton’s Third Law of Motion. (This heading is blocked, in 
part, by that pesky text box that still needs some work.)

2. In the Styles drawer, under Paragraph Styles, select Heading 1 (not 
heading 1).

The heading style is applied to the entire paragraph. 

3. Repeat steps 1 and 2 for the following heading paragraphs: Weight, 
Thrust, and Drag. 

4. Select the heading paragraph Profile Drag.

5. Use the Styles drawer to apply the Heading 2 (not heading 2) style to 
it.

6. Repeat steps 4 and 5 for the following heading paragraphs: Induced 
Drag, Parasite Drag, and Total Drag.

7. On page 7, select the paragraphs that begin with Form drag and Skin 
friction.

Note that in the Style drawer, the triangle beside Body under Para-
graph Styles is red (Figure 3.40). That’s because although the selection 
has the Body style applied to it, some of the selected text has additional 
styling applied. You can see which styles are applied when you look in the 
Character Styles section of the Styles drawer: both None and Emphasis 
are selected. That’s because some of the selection has no character styles 
applied and some of it has the Emphasis character style applied. 
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Figure 3.40: When text is selected, you can see what styles are applied by looking 
at the Styles drawer.

8. In the Styles drawer, select Body Bullet. 

The selected paragraphs are converted into a bulleted list Note that 
the first paragraph, which includes text with a character style applied, 
remains formatted as bold (Figure 3.41).

Figure 3.41: The selected text changes, but the character formatting is still applied.

Overwriting Imported Styles
As we saw earlier in the sections titled “Importing a Document” and 

“Adding Text with Drag & Drop,” when you import a Pages or Word 
document into your book as a chapter or section, you have the option 
of including or not including source document styles. We imported two 
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documents into this book; one with styles and the other without. So far, 
we’ve been working with the one imported without styles. Let’s take a look 
at what happens when we apply styles to the previous chapter, which was 
based on a Word document imported with styles.

1. In the Book pane, click the Section 1 thumbnail. 

As you can see, this section of the book has very different formatting 
(Figure 3.42). The styles assigned to the text are the same styles cre-
ated and assigned in the original Word document: heading 1, heading 2, 
Normal, and List Paragraph. 

Figure 3.42: This section’s formatting was carried forward from the original Word 
document and does not match Section 2.

To ensure consistent formatting throughout the book, we want to apply 
the built-in styles we used for Section 2.

2. Select the first paragraph on the right side of the page.

3. In the Paragraph Styles area of the Styles drawer, click Body.

The spacing and color of the paragraph’s text change (Figure 3.43).
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Figure 3.43: At first, it appears as if the built-in body style was properly applied.

Look at the Styles drawer. The triangle beside the Body style is red. 
That means that the full definition of the Body style is not applied to the 
text.

4. Click the red triangle to display a menu (Figure 3.44).

Figure 3.44: You can use this menu to make changes to the current style or the 
selected text.

What concerns us right now are the first three options:

 � Create Paragraph Style from Selection This command creates a brand 
new style based on the settings for the currently selected text.

 � Redefine Style from Selection This command changes the definition of 
the style so it matches the selected text. Note that if a variety of format-
ting was applied to the text, it would take the style applied to the first 
selected character.

 � Revert to Defined Style This command applies the full style definition 
to the selected text, thus overriding any other formatting applied to the 
text. This is the command we want right now.
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5. Choose Revert to Defined Style.

The text changes again with a larger character size and different 
spacing (Figure 3.45). This matches the Body style applied throughout 
Section 2.

Figure 3.45: The built-in Body style is fully applied to the text.

TIP Perhaps you can see now why I prefer to import files without formatting and 
format them within iBooks Author. It simply makes applying styles quicker and easier 
because I don’t need to perform this extra step. Of course, this would not be necessary 
if all your imported documents had the same styles applied.

Let’s try a shortcut to convert the rest of the text with the Normal style 
applied to the built-in Body style.

6. Click anywhere in the paragraph beneath the Airfoil heading.

7. In the Paragraph Styles area of the Styles drawer, click the black tri-
angle beside Normal to display the menu.

8. Choose Select All Uses of Normal.

Throughout the document, any text with the Normal style applied is 
selected.

9. In the Paragraph Styles area of the Styles drawer, click Body.

The style of the text changes to partially match the Body style.

10. In the Paragraph Styles area of the Styles drawer, click the red triangle 
beside Body to display the menu (Figure 3.44).

11. Choose Revert to Defined style.

The text is formatted with the full Body style definition. 
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12. Go through the rest of the section to reformat heading 1 text with 
Heading 1 and List Paragraph to Body Bullet. Be sure to use the menu 
in the Styles drawer to make sure the style is fully applied.

When you’re finished, the section’s pages should look like what you 
see in Figure 3.46. You may notice that although the section was only two 
pages long before you changed the formatting, it’s now three pages long. 
Not only did iBooks Author insert a new page for you, but it placed it in 
the correct section and flowed text into it as necessary.

Figure 3.46: Here’s a glimpse of what the pages in Section 1 should look like when 
you’re finished formatting them.

Modifying Styles
To change the look of text, all you need to do is redefine the style so it 

has new settings. The formatting changes are made universally, wherever 
the style was applied.
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Suppose we decide that the Heading 1 headings need to be larger, with 
more space above and below, and dark red. We can make those changes 
to one heading with that style applied and then use that as a sample to 
redefine the Heading 1 style.

Let’s give it a try. We’ll use the format bar and Text inspector, since 
between them, they offer access to just about all text formatting options. 
Keep in mind, however, that you can make changes to text using any of 
the direct text formatting tools discussed earlier in this chapter, in the sec-
tion titled “Directly Applying Formatting.”

1. Select any paragraph with the Heading 1 style applied.

2. On the format bar, use the Font Size menu to set the font size to 24.

3. On the format bar, click the Text Color button and use the Colors pane 
that appears to choose a dark red color.

4. In the Text panel of the Text inspector, set the Before paragraph 
option to 16 pt and the After Paragraph option to 8 points. 

It should look something like Figure 3.47 when you’re finished.

Figure 3.47: The modified heading.

5. Take a moment to scroll through the book’s pages. You’ll notice that 
only the selected heading has been changed.

6. With the modified heading still selected, click the red triangle beside 
the Heading 1 style in the Paragraph Styles area of the Styles drawer to 
display the menu (Figure 3.44).

7. Choose Redefine Style from Selection.
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A few things happen. First, the Heading 1 style in the Styles drawer 
changes so it looks like the heading you formatted. Second, if you scroll 
through the document again, you’ll see that all the text with the Heading 1 
style applied has been changed to match the heading you formatted. The 
style has been redefined and, throughout this document, will look like this 
whenever it is applied.

Sure beats manually making changes throughout the document!

Setting Column Options
You may have noticed that throughout our document, all regular text 

pages have appeared with two columns. You’re not stuck with this layout. 
You can change the number of columns that appears on a page. Let’s give 
this a try.

1. In the Book pane, click page 3 (the second page of Section 1).

2. Click anywhere in the text of the page to position the insertion point 
there.

3. Click the Number of Columns button in the format bar to display a 
menu (Figure 3.38).

Figure 3.48: You can use the Number of Columns button’s menu to set the number 
of text columns on the page.

4. Choose 3 Columns.
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The layout of the page changes to three columns (Figure 3.49). None of 
the other pages change.

Figure 3.49: Page 3, with a 3-column layout.

TIP You can fully customize the number of columns, column widths, and space 
between columns (gutter) in the Layout inspector. Explore those options on your 
own; a complete discussion is beyond the scope of this book.

Next Up
This chapter covered most of what you need to know to add text into 

your book using a number of different techniques. It also provided some 
very valuable information about the tools and methods for formatting 
text, including the use of styles to maintain consistency throughout your 
document.

In the next chapter, we’ll spruce up this document by adding a few 
photos and other images. Along the way, you’ll learn about resizing, 
moving, and editing images.
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